engine sputters when I punch it
#1
351W with 4160 Holley 600 4bbl vacuum secondary’s why does engine sputter when I punch it? No quick snap off the line. After 30 min drive car bogs down big time? Would like a recommendation for a mechanic to look at this in Brighton Michigan area. Anybody know somebody?
Reply
#2
I don't know anybody in that area.  There are many things that can cause your problem.  All are usually minor tune-up type of stuff.  If you have done some mechanical work you can probably fix it yourself with some suggestions/advise from members here.  Some possible causes of the sputtering when you punch it:  bad spark plug, bad spark plug wire, or bad ignition coil, accelerator pump in the carb is not tuned or working correctly, ignition timing too retarded and/or not advancing correctly.  When you say bog after 30 minutes of driving, you mean will not accelerate or slow to accelerate?  They seem like different issues but often the same cause for both.

Did both of these issues suddenly pop up?  Was the car sitting for a long period of time then these issues started?  Was other work done prior to these issues starting?
Reply
#3
Sorry - I do not know anyone in your area either.

But you have been given good advice above.  Any of the above or a combination of them could be the culprit.  Not knowing the history of what has or has not been done recently to your car would make me lean towards a fuel / carburetor issue.  Sitting for any prolonged length of time with today's fuel is a recipe for problems.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  First few runs after engine rebuild and she over heats rindel 55 32,914 09-15-2015, 05:29 PM
Last Post: 1969_Mach1
  Engine Won't Stop Running mason1958 8 8,228 06-16-2012, 10:07 AM
Last Post: 1969jimmach
Shocked Can't identify 2 wires after engine installation zekegood 5 5,895 08-10-2011, 11:26 AM
Last Post: 70427w

Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Latest Threads
"Jacobra"
Last Post: JTS71 Mach1
01-16-2019 02:21 PM
» Replies: 61
» Views: 11522
New addition to the stable..
Last Post: Steven Harris
01-16-2019 01:26 PM
» Replies: 5
» Views: 481
Dash ignition light?
Last Post: JTS71 Mach1
01-13-2019 11:17 AM
» Replies: 1
» Views: 165
Alternator Light Won't go off
Last Post: 1969_Mach1
01-06-2019 05:35 AM
» Replies: 13
» Views: 1579
Merry Christmas 2018
Last Post: Steven Harris
12-30-2018 12:56 PM
» Replies: 10
» Views: 701
Led lights not all that good.
Last Post: John
12-28-2018 02:12 PM
» Replies: 24
» Views: 7800
66 Fairlane Project
Last Post: Steven Harris
12-28-2018 01:03 PM
» Replies: 538
» Views: 135533
"70 Mach 1 Fuel Line Routing
Last Post: 1969_Mach1
12-28-2018 06:07 AM
» Replies: 1
» Views: 353
"70 Mach 1 with TCI torque Tube Rear Sus...
Last Post: 70MACH427
12-28-2018 05:31 AM
» Replies: 0
» Views: 287
Rear Spoiler Pitch/angle
Last Post: John
12-23-2018 11:31 AM
» Replies: 3
» Views: 3710
Tachometer Wiring
Last Post: Mustangmike
12-19-2018 08:39 PM
» Replies: 10
» Views: 1012
New member 1969 Mach 1
Last Post: Mustangmike
12-17-2018 09:00 AM
» Replies: 11
» Views: 1931
351c wont start, help
Last Post: JTS71 Mach1
12-16-2018 08:26 AM
» Replies: 71
» Views: 5332
PCM keeps burning out have replaced for...
Last Post: Mustangbob
12-11-2018 10:58 AM
» Replies: 8
» Views: 1052
70 Boss 302 - Night Mission build blog
Last Post: JTS71 Mach1
12-07-2018 01:12 PM
» Replies: 109
» Views: 75112
My newest 1970 Mustang Fastback 302
Last Post: BLACK JADE 69
12-04-2018 12:08 AM
» Replies: 24
» Views: 3211
New guy with a question.
Last Post: 1969_Mach1
12-03-2018 06:57 AM
» Replies: 25
» Views: 1899
Dashboard lights REALLY dim, any fixes??
Last Post: Steven Harris
12-01-2018 12:04 PM
» Replies: 13
» Views: 14798
new member
Last Post: Steven Harris
12-01-2018 12:02 PM
» Replies: 4
» Views: 717
1971-73 "Clydesdales"
Last Post: Mister 4x4
11-29-2018 11:35 AM
» Replies: 26
» Views: 2175

>