Turn signals not working
#1
Purchased my 72 Mach 1 in March.  The turn signals worked but now they don't.  I have replaced the flasher and the turn signal switch.  All fuses look good.  I do not hear any clicking in the flasher unit when the turn signals are used.  All lights are working including the hazard flashers. Any thoughts?  Appreciate any assistance.
Reply
#2
Other then trying another flasher can, just to be sure you haven't gotten a bad one. It sounds like you've replaced the only other piece which is the turn signal switch it self. It isn't impossible the turn signal switch itself could actually be bad? Have you checked for power at the signal can? You should have 12 volts on one side when the signal is activated. If not follow the wires back as they come out of the turn signal switch, don't forget they also go through the brake light switch as well. The more I think about it. I believe you have a problem in the new signal switch, seeing as your 4 ways work, but the signals don't??? and they come out of the same switch. Hope it helps. 

JTS
Reply
#3
Did you replace the right flasher can? There is one for the indicators and one for the hazard lights. You might have swapped out the wrong one? I think the one for the indicators is above the glove box.
Reply
#4
That's right I forgot there are 2 cans. God I hate getting old. 

JTS
Reply
#5
(09-12-2021, 02:21 AM)JTS71 Mach1 Wrote: That's right I forgot there are 2 cans. God I hate getting old. 

JTS
Thanks for the suggestions.  I was able to get them working again by cleaning up ground wires.
Reply
#6
Yep old cars and grounds can cause lots of problems. Glad you got it sorted out. 

JTS
Reply
#7
NICE!

What a great help you all are.  :)
Reply
#8
(09-12-2021, 11:32 AM)mccuner Wrote:
(09-12-2021, 02:21 AM)JTS71 Mach1 Wrote: That's right I forgot there are 2 cans. God I hate getting old. 

JTS
Thanks for the suggestions.  I was able to get them working again by cleaning up ground wires.

I have this same problem and can't figure it out. I replace and tested everything but turn signals don't work, although hazards do. You stated you cleaned some ground wires. What ground wires did you clean and where were they located?

Thanks,
Justin
Reply
#9
The grounds are all over the place. Anywhere you see a black wire attached to a stud or body/sheetmetal directly, that's a ground. If memory servers me right the first one 1. at the battery and solenoid area, should be a 3/8 headed screw straight into the inner fender panel, and goes straight to the negative battery post. 2. There is one at the back of the engine usually a braided cable to the firewall it's self. 3. I believe there is one at the bottom of the steering column which attaches to firewall. 4. there a couple grounds at the rear tail lights along the bottom edge of the taillight panel itself. 5. there is a ground stud up behind the heater box if I remember correctly. I know there are more but those are the ones that come to mind. Hope it helps.

JTS
Reply
#10
(03-03-2022, 08:11 AM)JTS71 Mach1 Wrote: The grounds are all over the place. Anywhere you see a black wire attached to a stud or body/sheetmetal directly, that's a ground. If memory servers me right the first one 1. at the battery and solenoid area, should be a 3/8 headed screw straight into the inner fender panel, and goes straight to the negative battery post. 2. There is one at the back of the engine usually a braided cable to the firewall it's self. 3. I believe there is one at the bottom of the steering column which attaches to firewall. 4. there a couple grounds at the rear tail lights along the bottom edge of the taillight panel itself. 5. there is a ground stud up behind the heater box if I remember correctly. I know there are more but those are the ones that come to mind. Hope it helps.

JTS

Sounds good, I'll update you after I clean them!
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Where's the turn signal flasher module? Holychrome 5 20,657 11-14-2017, 07:27 PM
Last Post: Desy141
  Temp gauge not working 72mach1 4 11,574 09-10-2014, 01:08 PM
Last Post: Steven Harris
  Park Brake Warning Light - Working Bluemach 3 10,341 07-13-2013, 04:47 AM
Last Post: Rare Pony
  whats going on with my turn signl switch? mlp40 2 8,288 10-07-2012, 10:58 PM
Last Post: ohiomustang
  Turn signal switch? mlp40 5 13,454 09-22-2012, 09:24 AM
Last Post: mlp40
  Temperature gauge not working...ideas? mlp40 9 23,374 09-25-2011, 12:13 PM
Last Post: mlp40
  turn signal slows down ken72 8 18,941 09-05-2011, 12:42 AM
Last Post: rvrtrash
  Engine won't turn off! Mach Man 11 26,063 09-05-2011, 12:37 AM
Last Post: rvrtrash

Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Latest Threads
hzfuchuntyre.com
Last Post: hk558hk
Today 03:09 PM
» Replies: 0
» Views: 0
351 cj running hot
Last Post: Vroll
Today 03:07 PM
» Replies: 0
» Views: 3
fd-corn.com
Last Post: hk558hk
Today 03:06 PM
» Replies: 0
» Views: 2
btshock.com
Last Post: hk558hk
Today 03:04 PM
» Replies: 0
» Views: 2
babyshoes2022.com
Last Post: hk558hk
Today 03:01 PM
» Replies: 0
» Views: 4
antboxfurniture.com
Last Post: hk558hk
Today 02:59 PM
» Replies: 0
» Views: 2
airhank.net
Last Post: hk558hk
Today 02:54 PM
» Replies: 0
» Views: 4
Major Winter projects
Last Post: JackWagon3
05-18-2022 08:59 PM
» Replies: 47
» Views: 8405
New
Last Post: Rare Pony
05-18-2022 01:54 PM
» Replies: 2
» Views: 93
Help/advice needed!!
Last Post: JTS71 Mach1
05-03-2022 03:42 AM
» Replies: 7
» Views: 545
WELCOME ALL NEW MEMBERS INTRODUCE YOURSE...
Last Post: JTS71 Mach1
05-02-2022 01:15 AM
» Replies: 77
» Views: 130484
Base suspension alignment/setup
Last Post: JTS71 Mach1
04-27-2022 11:49 AM
» Replies: 1
» Views: 240
Dash ignition light?
Last Post: JTS71 Mach1
04-11-2022 12:46 AM
» Replies: 5
» Views: 8471
Biden had to go to Hospital
Last Post: JTS71 Mach1
04-09-2022 02:02 AM
» Replies: 0
» Views: 727
That new/old Jeep smell
Last Post: JTS71 Mach1
04-02-2022 08:28 PM
» Replies: 34
» Views: 13412
Brake Lines - Distribution Block
Last Post: JTS71 Mach1
03-28-2022 10:49 AM
» Replies: 7
» Views: 1842
"Jacobra"
Last Post: JTS71 Mach1
03-28-2022 09:25 AM
» Replies: 83
» Views: 128348
Marriage
Last Post: JTS71 Mach1
03-27-2022 08:11 AM
» Replies: 0
» Views: 541
Newbie
Last Post: JTS71 Mach1
03-22-2022 12:47 PM
» Replies: 1
» Views: 474
Rear Spoiler Pitch/angle
Last Post: carguy47
03-22-2022 10:25 AM
» Replies: 4
» Views: 10285

>