Newbie - Just brought this baby home
#1
Hi Y'all,

Just found this group...glad to be part of the Mach 1 family.  Just purchased a 1973 H-Code Mach 1 last week and have been doing some research on what's out there...

This is a locally owned car and I'm the 3rd owner...  It has 46,861 miles on it and looks to be in great shape.  Is been sitting in a garage until 2001 with the original owner.  His son then had it for a while and then the guy I got it from last week had it for about a year and is been sitting.  Engine sounds great.  Rear drive shaft cause it to shake a little, but otherwise, seems to be mechanically and cosmetically pretty good.

Even have the original title to the car (the 2nd owner kept the original title) and all the paperwork including the window sticker...wish Mustangs still cost this much today :-)

Spent a day cleaning the engine and interior...and will start to tackle it one thing at a time.

Did run into a problem...trying to figure out why the instrument panel/radio/headlight not working...check the fuse, seems to ok. not sure if the contact in the fusebox is dirty or what.  can't find anything online on what to look for in trying to trouble shoot that

Looking forward to bringing this baby back to is original beauty!


Attached Files Image(s)
                       

.pdf   window_sticker.pdf (Size: 829.36 KB / Downloads: 4)
Reply
#2
Welcome to the site.  It looks like you found a pretty solid, low mileage and mostly original car. Except for the tears in the driver's seat the interior looks to be in really good shape. By the looks of the faded paint the car looks like it had spent it life in a dry climate and should be an easy restoration back to original.

In regards to the electrical problem did you use a test light to check the fuses?  Sometimes it is difficult to tell if the fuses are blown by visual inspection.   If you have a test light, place the pointer at the end of each fuse.  The test light should light up when you touch each end of the fuse.  If it only lights up on one side then you have a bad fuse.  You may have to turn your key one click to the right for this test so there is power.  I would start with testing the fuses first. If your fuses are good, you will have to see if you have power going to the components that are not working. This can be done with a test light as well. Other possibilities are dead bulbs, poor connections, or even possibly a grounding issue.  Once again, I would start with the fuse box to rule out that out first.  You didn't mention if your windshield wipers work?

Mike
Reply
#3
Thanks mike, I will try that...the wipers, radio, headlight, heat/air/fan...none of those work, which from what I read is all tied to that one fuse.  I looked online at CJ and is strange that their fuse kit only include the 2amp for that fuse and not a 4amp...
Reply
#4
(01-31-2019, 06:11 AM)sonicboom Wrote: Thanks mike, I will try that...the wipers, radio, headlight, heat/air/fan...none of those work, which from what I read is all tied to that one fuse.  I looked online at CJ and is strange that their fuse kit only include the 2amp for that fuse and not a 4amp...

Definitely sounds like a fuse box issue since nothing seems to be working. You may have to pull the fuses and inspect the fuse box contacts. They may need to be cleaned up and new fuses put in. It is not uncommon to have corrosion on the contacts where the fuses push into. It can be a little tedious cleaning them but it can be done with a little patience. I am not so familiar with the 71-73 Mustangs but I thought the correct fuse for the switched accessories and headlights is a 14A.  Let me know how you make out with testing the fuses.
Reply
#5
Welcome, looks Pretty Good for 46 year old. Got all the Right Bumps, in all the Right Places. LOL!  Laughing The back of the fuse box mates with the underhood harness, and the connections are prone to corrosion damage etc. This is where all the main power comes in from the battery, and feeds the entire car so you may have a issue where the two halves come together? Hope it helps. 

JTS
Reply
#6
Welcome!

Very nice find.

It sounds like you have been given good advice on your electrical problem.  Using either a meter or a simple 12V test light you should be able to test wires, fuse ends, etc. and come up with the problem.

Thanks for joining and thanks for sharing the pictures.
Reply
#7
Welcome to the site from Virginia.  Looks like a solid 73. Good tips on the electrical system. I remember having to clean the contacts on my fuse block on my 73 convertible. Hopefully that will work for you too.
Reply
#8
I am glad to see this thread pop up again.  Sonic Boom, just curious if you where you able to fix the electrical problem? 

Mike
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  newbie carmans69 7 2,637 04-27-2020, 10:56 PM
Last Post: BLACK JADE 69
  Newbie dmiles 6 2,318 01-20-2020, 01:56 AM
Last Post: Mustangmike
  newbie here mmcmike2006 5 9,079 05-26-2015, 09:47 AM
Last Post: Zagnut
  Newbie to the herd notagt 5 9,911 04-27-2015, 12:37 PM
Last Post: Rsmach1
  SoCal newbie Rsmach1 5 9,420 04-25-2015, 11:03 PM
Last Post: Mach1FatherFigure
  Newbie from NM MeJay Racing 4 8,302 03-20-2015, 10:49 AM
Last Post: Mach1FatherFigure
  Newbie saying hi nbracken 3 6,918 01-06-2015, 01:14 PM
Last Post: JTS71 Mach1
  NEWBIE NicBerg 6 9,674 09-30-2014, 10:43 PM
Last Post: ohiomustang
  Newbie hemi62valiant 7 10,885 07-15-2014, 06:12 AM
Last Post: ninja85
  1971 newbie Klinton994 5 9,863 05-31-2014, 05:34 AM
Last Post: BLACK JADE 69

Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Latest Threads
Just joined
Last Post: JTS71 Mach1
Today 10:48 AM
» Replies: 2
» Views: 34
Fuel pump & carb replacement
Last Post: 1969_Mach1
Today 09:02 AM
» Replies: 6
» Views: 222
Been Awhile... '71 Rustang
Last Post: Mister 4x4
07-09-2020 10:42 AM
» Replies: 176
» Views: 208745
Pulling the motor
Last Post: JTS71 Mach1
07-08-2020 07:40 AM
» Replies: 7
» Views: 206
The 2021 Ford Mustang Mach 1 Is Back Wit...
Last Post: JTS71 Mach1
07-07-2020 09:31 AM
» Replies: 5
» Views: 459
1969 Mach1 Parking light socket with wir...
Last Post: JTS71 Mach1
07-07-2020 09:29 AM
» Replies: 1
» Views: 137
Ford unveils 2021 Mustang Mach 1
Last Post: Mister 4x4
07-06-2020 06:17 AM
» Replies: 2
» Views: 671
Happy Father's Day
Last Post: JTS71 Mach1
06-22-2020 01:24 AM
» Replies: 0
» Views: 301
2021 Ford Mustang Mach 1 builds a bridge...
Last Post: Mach 1 Club
06-17-2020 01:20 AM
» Replies: 0
» Views: 584
Daddy's Home!
Last Post: JTS71 Mach1
06-09-2020 12:05 PM
» Replies: 0
» Views: 3246
Need paint match advise from expert auto...
Last Post: Mustangmike
06-07-2020 11:55 PM
» Replies: 2
» Views: 1046
Tool Kit Suggestions
Last Post: AGON123
06-05-2020 05:55 PM
» Replies: 25
» Views: 37031
Spark plugs
Last Post: JTS71 Mach1
05-28-2020 02:45 AM
» Replies: 11
» Views: 2752
Memorial Day
Last Post: JTS71 Mach1
05-26-2020 04:47 AM
» Replies: 0
» Views: 1429
WTB 69-70 Fastback Quarter Window Latch ...
Last Post: SWPruett
05-19-2020 11:11 AM
» Replies: 2
» Views: 1446
Heater Box Question
Last Post: bob.harlan
05-18-2020 02:23 AM
» Replies: 2
» Views: 1379
Brassiere
Last Post: JTS71 Mach1
05-17-2020 05:44 AM
» Replies: 0
» Views: 2960
Why I'm in Love with my car
Last Post: carmans69
05-01-2020 03:19 PM
» Replies: 5
» Views: 1997
Anyone own a car sold new by Sud Automob...
Last Post: Raytags
05-01-2020 02:17 AM
» Replies: 0
» Views: 1423
newbie
Last Post: BLACK JADE 69
04-27-2020 10:56 PM
» Replies: 7
» Views: 2637

>