Fuse Panel on my ‘69
#1
Just bought a ‘69 and have a few electrical issues.  I checked out the fuses and found them all good except for the short stubby 4A that controls instrument lamps, clock, etc.  I don’t have power on either end of this fuse so it is not simply a bad fuse.  Anyone run into a similar problem and, if so, what was your solution.  Could this problem just be a bad fuse panel?
Thanks
Reply
#2
One possibility is dirty contacts in the light switch. The instrument lamps are controlled by a rheostat that maybe dirty. Try rotating the switch knob back and forth several times. That worked on mine.
Reply
#3
(02-06-2019, 06:18 AM)bob.harlan Wrote: One possibility is dirty contacts in the light switch. The instrument lamps are controlled by a rheostat that maybe dirty. Try rotating the switch knob back and forth several times. That worked on mine.

Tried that but did not work for me.  Tomorrow I will make up a jumper wire with an in-line fuse and see what I can figure out.

Thanks for the suggestion!
Reply
#4
Just to confirm, you did have the ignition key in the run position while you were checking the fuses?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  1969 blower motor keeps blowing fuse rindel 8 9,098 01-05-2015, 12:08 AM
Last Post: rindel

Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Latest Threads
hdshadpar
Last Post: Steven Harris
02-17-2019 02:25 PM
» Replies: 3
» Views: 159
UK Mach1
Last Post: Steven Harris
02-17-2019 02:16 PM
» Replies: 2
» Views: 179
1971 Boss 351
Last Post: Steven Harris
02-17-2019 02:10 PM
» Replies: 4
» Views: 161
Vin Decoder
Last Post: JTS71 Mach1
02-16-2019 08:53 AM
» Replies: 8
» Views: 5374
Bonnet latches
Last Post: JTS71 Mach1
02-13-2019 02:11 PM
» Replies: 2
» Views: 194
Vin decoder
Last Post: Oztrailer
02-11-2019 07:56 PM
» Replies: 1
» Views: 225
Ignition Timing
Last Post: JTS71 Mach1
02-10-2019 09:37 AM
» Replies: 23
» Views: 3965
"Jacobra"
Last Post: JTS71 Mach1
02-10-2019 09:18 AM
» Replies: 62
» Views: 14669
New Member
Last Post: Mustangmike
02-07-2019 09:25 PM
» Replies: 8
» Views: 540
Fuse Panel on my ‘69
Last Post: 1969_Mach1
02-06-2019 06:28 PM
» Replies: 3
» Views: 301
66 Fairlane Project
Last Post: Mustangmike
02-03-2019 10:42 PM
» Replies: 542
» Views: 158482
1973 Mach 1 parts
Last Post: Steven Harris
02-03-2019 06:37 AM
» Replies: 5
» Views: 568
Newbie - Just brought this baby home
Last Post: Steven Harris
02-03-2019 06:33 AM
» Replies: 5
» Views: 615
This One's Funny!
Last Post: JTS71 Mach1
02-01-2019 10:08 AM
» Replies: 2
» Views: 388
Dash ignition light?
Last Post: JTS71 Mach1
01-21-2019 10:37 AM
» Replies: 3
» Views: 797
New addition to the stable..
Last Post: Steven Harris
01-16-2019 01:26 PM
» Replies: 5
» Views: 928
Alternator Light Won't go off
Last Post: 1969_Mach1
01-06-2019 05:35 AM
» Replies: 13
» Views: 2187
Merry Christmas 2018
Last Post: Steven Harris
12-30-2018 12:56 PM
» Replies: 10
» Views: 1225
Led lights not all that good.
Last Post: John
12-28-2018 02:12 PM
» Replies: 24
» Views: 9458
"70 Mach 1 Fuel Line Routing
Last Post: 1969_Mach1
12-28-2018 06:07 AM
» Replies: 1
» Views: 620

>