a couple of questions for a restomod
#11
(03-16-2015, 11:14 PM)Mach1FatherFigure Wrote: I was under the impression that 20w-50 is the oil the engine was built for and can be used from temporate to sub tropical temperature zones. I use GTX 20w-50 in my older cars all year round here.

I have only seen a couple of temp vs. viscosity charts. Both listed 20w-50 for temps no lower than 32 deg. F. I don't know if there is a more complete and accurate source.

Best Regards,
Mike

Reply
#12
One question that wasn't asked is - Have the front springs been changed? I've seen so many guys swap big motors into cars which originally had small blocks or sixes. They drop a big heavy V-8 in it and the springs aren't up to task. It will also throw off your front end alignment. (read geometry) Assuming your steering linkage is all good, have you checked your ride height? (front versus rear) Do you have power or manual steering and what kind of steering box?
Reply
#13
So i ended up just draining everything out and going with valvoline vr1. Did some more work and found the head gaskets to be really warped out of shape. i think they were too big, anyway ended up replacing them, now i can idle better!.
i'm not sure if the springs in the front were replaced to accommodate the weight of the engine though, definitely something ill need to look into. starting to find more problems but hey, old car right? next on the list is hydroboost, and figuring out how I'm going to replace the front driveshaft, i think its way too exposed, roughly 4 inches. thanks again to everyone who contributed their knowledge to this thread.

phil
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Latest Threads
PCM keeps burning out have replaced for...
Last Post: Mustangbob
Yesterday 10:58 AM
» Replies: 8
» Views: 214
70 Boss 302 - Night Mission build blog
Last Post: JTS71 Mach1
12-07-2018 01:12 PM
» Replies: 109
» Views: 67853
Alternator Light Won't go off
Last Post: 1969_Mach1
12-05-2018 11:56 AM
» Replies: 10
» Views: 489
"Jacobra"
Last Post: Steven Harris
12-04-2018 02:36 PM
» Replies: 55
» Views: 8293
My newest 1970 Mustang Fastback 302
Last Post: BLACK JADE 69
12-04-2018 12:08 AM
» Replies: 24
» Views: 1815
351c wont start, help
Last Post: 1969_Mach1
12-03-2018 06:35 PM
» Replies: 62
» Views: 2078
New guy with a question.
Last Post: 1969_Mach1
12-03-2018 06:57 AM
» Replies: 25
» Views: 768
Dashboard lights REALLY dim, any fixes??
Last Post: Steven Harris
12-01-2018 12:04 PM
» Replies: 13
» Views: 13577
new member
Last Post: Steven Harris
12-01-2018 12:02 PM
» Replies: 4
» Views: 270
1971-73 "Clydesdales"
Last Post: Mister 4x4
11-29-2018 11:35 AM
» Replies: 26
» Views: 916
Installing Factory gauges in a '71-'73 M...
Last Post: Mister 4x4
11-28-2018 03:26 AM
» Replies: 4
» Views: 758
Pictures and some info from a new guy
Last Post: Mister 4x4
11-28-2018 03:02 AM
» Replies: 18
» Views: 1199
Been Awhile... '71 Rustang
Last Post: Mister 4x4
11-24-2018 01:49 PM
» Replies: 143
» Views: 92629
1965 Fairlane (Mustangmike)
Last Post: JTS71 Mach1
11-23-2018 02:56 PM
» Replies: 14
» Views: 768
Happy Thanks Giving!!!
Last Post: 1969_Mach1
11-23-2018 03:42 AM
» Replies: 2
» Views: 295
How not to Handle A DUI Checkpoint?!?!
Last Post: Vanbens91
11-14-2018 07:22 PM
» Replies: 1
» Views: 2134
Led lights not all that good.
Last Post: Mustangmike
11-14-2018 09:44 AM
» Replies: 20
» Views: 5642
1972 Mach1 rear fold down seat problems....
Last Post: John
11-13-2018 03:04 AM
» Replies: 10
» Views: 704
1972 Mach1 parts
Last Post: John
11-10-2018 10:31 AM
» Replies: 0
» Views: 234
COIL SPRINGS
Last Post: 1969_Mach1
11-08-2018 09:43 AM
» Replies: 5
» Views: 398

>